windows-amd64-prebuilt-libr.../vcpkg/ports/proxywrapper/fix-find-libproxy.patch
2020-10-10 14:36:42 +02:00

21 lines
643 B
Diff

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5a867a4..3ba85fa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,11 +5,12 @@ project(proxywrapper)
include(GNUInstallDirs)
-find_library(proxy REQUIRED)
+find_package(libproxy REQUIRED)
-add_library(proxywrapper SHARED ProxyWrapper.cpp)
+add_library(proxywrapper ProxyWrapper.cpp)
-target_link_libraries(proxywrapper proxy)
+target_link_libraries(proxywrapper PRIVATE ${LIBPROXY_LIBRARIES})
+target_include_directories(proxywrapper PRIVATE ${LIBPROXY_INCLUDE_DIR})
install(TARGETS proxywrapper EXPORT proxywrapper DESTINATION ${CMAKE_INSTALL_LIBDIR})