windows-amd64-prebuilt-libr.../vcpkg/ports/zlib/add_debug_postfix_on_mingw.patch
2020-10-10 14:36:42 +02:00

14 lines
348 B
Diff

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0fe939d..e4fc213 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -59,7 +59,7 @@ endif()
#
check_include_file(unistd.h Z_HAVE_UNISTD_H)
-if(MSVC)
+if(WIN32)
set(CMAKE_DEBUG_POSTFIX "d")
add_definitions(-D_CRT_SECURE_NO_DEPRECATE)
add_definitions(-D_CRT_NONSTDC_NO_DEPRECATE)